Saturday, 19 July 2014

finally figured it out!

There are a number of people still using Dell 1501 Inspiron laptops. A lot of them are running the Microsoft Vista OS. Most of them seem to have an issue with battery life and/or the system reporting that their battery is unrecognized, needs to be replaced, or will not charge.

Seeing that there was a new version that supposedly fixed this problem, I have tried more than once to update the BIOS on this laptop. It has never worked. As it is not mine, I have not put 100% effort into finding a solution (my bad).

It has come to pass that this laptop is now surplus and can be re-purposed. Getting it running without problems is now more important. I've read every post I could find on the Internet of other people's trials and tribulations with the same issue. Suggestions run from reloading the OS from scratch, to a do-this-then-that hoop-jumping sequence that will make your eyes glaze over. Having just spent a few evenings reloading a different PC with Vista, going through the 170+ updates, re-installing all the applications, and configuring the user accounts, I had no desire to repeat the performance.

So finally (after much head scratching) I got it to work.

This is the 32-bit Vista system that has been upgraded to 2Gb of RAM. Everything else is stock (15.4" XGA, 1.6 GHzTurion processor, Broadcom DW1390 card, etc.)

Dell wants you to download and copy the Win1501263.EXE file to your desktop and execute it from within Vista. This is supposed to extract the new (and last) BIOS image (2.6.3, A16), backup your current BIOS, and write the new BIOS to the motherboard using the WinPhlash utility.

Doing this sort of thing typically requires Administrator privileges, and this instance is no exception.

However, no matter in which order things were clicked, which user account I was logged in under, or even if I ran the Win1501263.EXE self-extract "as administrator", either nothing would happen or the WinPhlash utility would fail with an error. Could be in safe mode, at the command prompt, whatever.

In the end, all it took was to remove the password from the Administrator account, reboot and allow the laptop to enter Vista without a password, and then run the utility from the desktop "as administrator". 

WinPhlash started, asked for an image file, and ran OK. It reported successfully updating the BIOS. I selected"restart" from the Windows menu once it had all finished, and got a weird looking blue screen full of gibberesh during the shutdown - for a moment I thought it had been bricked. But a power-reset led to a clean bootup - WITHOUT the usual warning that the battery could not be recognized during POST. The system then continued on and entered Vista without problem. Within the OS it did once again report that the battery needed to be replaced, however all subsequent boots have not had this warning come up at the POST or within Vista.

The only other thing I've noticed that is different since the update is the F12 boot menu now has a couple more options, including booting from USB media.

Hope this is info helpful to someone else.

No comments:

Post a comment